SNMPとTelemetryの特徴【前編】
ネットワーク監視に欠かせない「SNMP」と「Telemetry」の仕組みとは
ネットワーク管理者はネットワークのパフォーマンスや障害の予兆などを監視しなければならない。監視のための仕組みは「SNMP」と「Telemetry」がある。両者の特徴とは。
ネットワーク監視の仕組みには、「SNMP(Simple Network Management Protocol:簡易ネットワーク管理プロトコル)と「Telemetry」(以下、テレメトリー)がある。ネットワーク管理者はSNMPとTelemetryをどのように使い分ければいいのか。それぞれの特徴とは。
SNMPの仕組みとは
SNMPはインターネット技術の仕様を記した文書である「RFC」(Request for Comments)の「RFC 1098」として策定された。それ以来、さまざまな組織がネットワークの監視にSNMPを利用している。
SNMPはポーリング(一定の間隔で対象を定期的にチェックする手法)方式で、ネットワーク内のデバイスが送受信するデータ量や稼働状況などのパフォーマンスに関するデータを収集して、管理者に返す。
SNMPに準拠しているネットワーク機器はMIB(管理情報ベース)と呼ばれるデータベースを保持している。MIBには管理対象となるネットワーク機器の情報が記述されており、各機器をOID(オブジェクトID)で識別する。ネットワーク管理者はSNMPを利用時に、主に次の3つのリクエストによって、定期的あるいは必要に応じてネットワーク機器を監視する。
- GetRequest
- MIB内の特定のOIDの値を要求する。
- GetNextRequest
- MIB内の特定のOIDの次の値を要求する。
- GetBulkRequest
- 複数のOIDの値をまとめて要求する。
「RFC 1213」ではMIBの新たなバージョンとして「MIB-II」が定義された。MIB-IIではさまざまな仕様の標準化が進み、管理者はベンダーに依存せずにSNMPを利用しやすくなった。
SNMPの特徴としては、シンプルな通信プロトコル「UDP」(User Datagram Protocol)を利用するため、ネットワーク監視に必要な処理の負荷を比較的抑えることができる点が挙げられる。
だが、SNMPではポーリングのたびに、管理サーバ側からネットワーク内の各機器に情報を要求する。そのため、ポーリングの頻度次第でネットワーク内の各機器への負荷が増す。
テレメトリーの仕組み
テレメトリーによるネットワーク監視の仕様は「RFC 9232」で「Network Telemetry Framework」で策定されている。ポーリング方式のSNMPと比較して、テレメトリーではネットワーク機器から継続的にデータを送信する。そのため、SNMPに比べてネットワークの情報をリアルタイムに把握しやすくなる。
ただし、常にリアルタイムの情報を取得すると管理サーバ側が処理するデータ量が膨大になってしまう。そのため、ネットワーク管理者は、ネットワークにおける特定の項目のしきい値を超えた場合など、あらかじめ設定したイベントをトリガーとして、テレメトリーで監視を開始できる。特定のエラーの発生をトリガーとすることも可能だ。イベントを起点とした情報の収集はSNMPも可能だが、テレメトリーの方がよりリアルタイムかつ信頼性の高いネットワーク監視情報を手に入れることができる。
テレメトリーで主に利用されるデータ形式は以下の通り。
- XML(Extensible Markup Language)
- JSON(JavaScript Object Notation)
- Protocol Buffers
テレメトリーで主に利用される通信プロトコルは以下の通り。
- TCP(Transmission Control Protocol)
- UDP(User Datagram Protocol)
- gRPC(Google Remote Procedure Calls)
- gNMI(gRPC Network Management Interface)
テレメトリーを利用するとデータが膨大になる恐れがある。ネットワーク管理者は、ネットワーク管理システムの処理能力を圧迫しないよう、各種データをストリーミングするための間隔やイベントトリガーを決定しなければならない。
次回はSNMPとテレメトリーを比較する。
TechTarget発 先取りITトレンド
米国Informa TechTargetの豊富な記事の中から、最新技術解説や注目分野の製品比較、海外企業のIT製品導入事例などを厳選してお届けします。
Copyright © ITmedia, Inc. All Rights Reserved.
Computer Weekly発 世界に学ぶIT導入・活用術
この記事の著者
関連記事
新着ホワイトペーパー PR
-
事例
[株式会社キーエンス] PCが苦手でも自動化できる 近鉄コスモスなど4事例に学ぶ「ナビ搭載型RPA」活用 -
製品資料
[レノボ・ジャパン合同会社] 約1.39kgにAI処理能力を凝縮 持ち運べるAPU搭載ワークステーションの実力は? -
製品レビュー
[ネットアップ合同会社] ランサムウェア被害からの回復を阻む最大の壁とは? -
製品レビュー
[ネットアップ合同会社] 攻撃者は“最後の砦”を真っ先に狙う いま必要なランサムウェア対策とは? -
市場調査・トレンド
[Snowflake合同会社] AI時代のビジネスインテリジェンス変革:5大トレンドと成功戦略
こんなメディアも見られています
TechTargetジャパンに関連する情報をお探しであれば、こちらのメディアもお役に立てるかもしれません。
ベンダーコンテンツ PR
From Informa TechTarget
SpecialPR
アクセスランキング
-
1
「Active Directory」復旧で“詰む”企業が続出 ランサムウェアに備える4対策
-
2
なぜ「WSUS」を捨てない? 非推奨でも35%が使い続けるワケ
-
3
「AI時代の統合基盤・エンタープライズAI管理」に関するアンケート
-
4
1巻40TB、量子解読も防ぐ「LTO-10」 テープを侮るバックアップの盲点
-
5
なぜMicrosoftは「Rust」を標準言語に? AIで進むC/C++書き換えの課題
-
6
クラウド時代にあえて「メインフレーム」を選びたくなる理由はこれだ
-
7
なぜサーバ価格は下がらないのか? メモリ不足は2027年も続く
-
8
Microsoft 365統一で「SharePoint」が1日2TB増 富士フイルムはどう管理した?
-
9
8割がアナログに逆戻りする“やっぱりな理由” DXを阻む2つの落とし穴
-
10
AIエージェント導入が「PoC止まり」になる企業に共通する問題点とは?
ホワイトペーパーランキング PR
-
1
「IT史に名を残すシステム障害」8選
-
2
AIが苦手な「汚いデータ」になっていない? AI投資を無駄にしないための注意点
-
3
急増する高度なフィッシング詐欺 先回りしてブロックするには何が必要?
-
4
法人向け光回線のプランはどう選ぶ? 機能面/保守体制/コストを一覧で比較
-
5
三井ホームに学ぶ「無線LAN環境」構築 快適なオフィスと高度なIT運用の両立法
-
6
SNMPより詳細で、パケット解析より簡単な「トラフィック可視化・分析」の方法
-
7
Microsoft 365のメールセキュリティ、3つの“死角”と追加で検討すべき対策とは
-
8
「RPA導入の成果が出ない」を防ぐ、成果につながる自動化対象業務の選び方
-
9
10G回線の真価をフルに享受するには? 導入前にチェックしたいポイント
-
10
サイバー脅威「トップ50」完全解説ガイド、新たな攻撃手法に対抗するには
TechTargetジャパン SNS
インフォメーション
注目情報をチェック
TechTargetジャパンをフォロー