SNMPとTelemetryの特徴【前編】
ネットワーク監視に欠かせない「SNMP」と「Telemetry」の仕組みとは
ネットワーク管理者はネットワークのパフォーマンスや障害の予兆などを監視しなければならない。監視のための仕組みは「SNMP」と「Telemetry」がある。両者の特徴とは。
ネットワーク監視の仕組みには、「SNMP(Simple Network Management Protocol:簡易ネットワーク管理プロトコル)と「Telemetry」(以下、テレメトリー)がある。ネットワーク管理者はSNMPとTelemetryをどのように使い分ければいいのか。それぞれの特徴とは。
SNMPの仕組みとは
SNMPはインターネット技術の仕様を記した文書である「RFC」(Request for Comments)の「RFC 1098」として策定された。それ以来、さまざまな組織がネットワークの監視にSNMPを利用している。
SNMPはポーリング(一定の間隔で対象を定期的にチェックする手法)方式で、ネットワーク内のデバイスが送受信するデータ量や稼働状況などのパフォーマンスに関するデータを収集して、管理者に返す。
SNMPに準拠しているネットワーク機器はMIB(管理情報ベース)と呼ばれるデータベースを保持している。MIBには管理対象となるネットワーク機器の情報が記述されており、各機器をOID(オブジェクトID)で識別する。ネットワーク管理者はSNMPを利用時に、主に次の3つのリクエストによって、定期的あるいは必要に応じてネットワーク機器を監視する。
- GetRequest
- MIB内の特定のOIDの値を要求する。
- GetNextRequest
- MIB内の特定のOIDの次の値を要求する。
- GetBulkRequest
- 複数のOIDの値をまとめて要求する。
「RFC 1213」ではMIBの新たなバージョンとして「MIB-II」が定義された。MIB-IIではさまざまな仕様の標準化が進み、管理者はベンダーに依存せずにSNMPを利用しやすくなった。
SNMPの特徴としては、シンプルな通信プロトコル「UDP」(User Datagram Protocol)を利用するため、ネットワーク監視に必要な処理の負荷を比較的抑えることができる点が挙げられる。
だが、SNMPではポーリングのたびに、管理サーバ側からネットワーク内の各機器に情報を要求する。そのため、ポーリングの頻度次第でネットワーク内の各機器への負荷が増す。
テレメトリーの仕組み
テレメトリーによるネットワーク監視の仕様は「RFC 9232」で「Network Telemetry Framework」で策定されている。ポーリング方式のSNMPと比較して、テレメトリーではネットワーク機器から継続的にデータを送信する。そのため、SNMPに比べてネットワークの情報をリアルタイムに把握しやすくなる。
ただし、常にリアルタイムの情報を取得すると管理サーバ側が処理するデータ量が膨大になってしまう。そのため、ネットワーク管理者は、ネットワークにおける特定の項目のしきい値を超えた場合など、あらかじめ設定したイベントをトリガーとして、テレメトリーで監視を開始できる。特定のエラーの発生をトリガーとすることも可能だ。イベントを起点とした情報の収集はSNMPも可能だが、テレメトリーの方がよりリアルタイムかつ信頼性の高いネットワーク監視情報を手に入れることができる。
テレメトリーで主に利用されるデータ形式は以下の通り。
- XML(Extensible Markup Language)
- JSON(JavaScript Object Notation)
- Protocol Buffers
テレメトリーで主に利用される通信プロトコルは以下の通り。
- TCP(Transmission Control Protocol)
- UDP(User Datagram Protocol)
- gRPC(Google Remote Procedure Calls)
- gNMI(gRPC Network Management Interface)
テレメトリーを利用するとデータが膨大になる恐れがある。ネットワーク管理者は、ネットワーク管理システムの処理能力を圧迫しないよう、各種データをストリーミングするための間隔やイベントトリガーを決定しなければならない。
次回はSNMPとテレメトリーを比較する。
TechTarget発 先取りITトレンド
米国Informa TechTargetの豊富な記事の中から、最新技術解説や注目分野の製品比較、海外企業のIT製品導入事例などを厳選してお届けします。
Copyright © ITmedia, Inc. All Rights Reserved.
Computer Weekly発 世界に学ぶIT導入・活用術
この記事の著者
関連記事
新着ホワイトペーパー PR
-
事例
[日本オラクル株式会社] ピンチをチャンスに変えたEPR製品は? 先行企業の導入事例3選 -
技術文書・技術解説
[日本オラクル株式会社] 無自覚なリスク 秘伝Excelファイルが監査の壁、不正・ミスの温床となる理由 -
製品資料
[日本オラクル株式会社] 戦略的経理の第一歩 失敗のない「脱Excel」を実現する秘訣とは? -
技術文書・技術解説
[日本オラクル株式会社] いまさら聞けないオンプレERPとクラウドERPの違い 最適な製品をどう見極める? -
事例
[株式会社ビザスク] 連結売上高が約2倍に成長、富士フイルムが実践した新規事業創出の戦略とは?
こんなメディアも見られています
TechTargetジャパンに関連する情報をお探しであれば、こちらのメディアもお役に立てるかもしれません。
ベンダーコンテンツ PR
From Informa TechTarget
SpecialPR
アクセスランキング
-
1
損保ジャパンはなぜ「COBOL」を捨てなかったのか? 脱メインフレームの真相
-
2
なぜ「全社配布Copilot」は使われないのか? 失敗に学ぶAI定着
-
3
慶應義塾が「Notion」を選んだ理由 AI導入の盲点になる“情報のサイロ化”
-
4
「企業内サーバ環境の利用実態」に関するアンケート
-
5
エンジニアの生産性はどう測る? マネジメントに不可欠な可視化の実現方法とは
-
6
「ノートPC派」は損をしている? Dellと考える“自作PC”のメリット
-
7
「IoT通信環境の構築・運用」に関するアンケート
-
8
大阪証券取引所がHiRDBで実現した「世界トップレベルの応答速度」を誇る新売買システム
-
9
「Copilot」はなぜ放置される? “議事録要約止まり”を脱する処方箋
-
10
ただなのに「12時間以内の復旧」も要求 無償OSSに商用レベルを求める企業の末路
ホワイトペーパーランキング PR
-
1
DX/AI投資の壁を突破、現代の最高財務責任者が直面する課題と克服のヒント
-
2
不審メールの経路や見せ方に変化? 2026年夏の3事例から見えた動向と対処方法
-
3
「オンプレミス回帰」せざるを得ない“合理的な理由”
-
4
バックアップは“取っているから大丈夫”なのか? ランサムウェア時代の備え方
-
5
システムの保守がモダン化を阻む? 「変えない判断」から脱却する方法とは
-
6
生成AIを開発に導入しても効果が見えない? 実証実験で分かった成果と課題
-
7
経産省DX指針から読み解く、受発注業務デジタル化ロードマップ
-
8
5分で分かる Microsoft 365のデータ損失に備えるためのバックアップの仕組み
-
9
ネットワーク遅延の原因、「パケットロス」の基礎知識と効果的な解決策
-
10
Microsoft 365を安全に運用 うっかりミスやサイバー攻撃に備えるデータ保護術
TechTargetジャパン SNS
インフォメーション
注目情報をチェック
TechTargetジャパンをフォロー