SNMPとTelemetryの特徴【前編】
ネットワーク監視に欠かせない「SNMP」と「Telemetry」の仕組みとは
ネットワーク管理者はネットワークのパフォーマンスや障害の予兆などを監視しなければならない。監視のための仕組みは「SNMP」と「Telemetry」がある。両者の特徴とは。
ネットワーク監視の仕組みには、「SNMP(Simple Network Management Protocol:簡易ネットワーク管理プロトコル)と「Telemetry」(以下、テレメトリー)がある。ネットワーク管理者はSNMPとTelemetryをどのように使い分ければいいのか。それぞれの特徴とは。
SNMPの仕組みとは
SNMPはインターネット技術の仕様を記した文書である「RFC」(Request for Comments)の「RFC 1098」として策定された。それ以来、さまざまな組織がネットワークの監視にSNMPを利用している。
SNMPはポーリング(一定の間隔で対象を定期的にチェックする手法)方式で、ネットワーク内のデバイスが送受信するデータ量や稼働状況などのパフォーマンスに関するデータを収集して、管理者に返す。
SNMPに準拠しているネットワーク機器はMIB(管理情報ベース)と呼ばれるデータベースを保持している。MIBには管理対象となるネットワーク機器の情報が記述されており、各機器をOID(オブジェクトID)で識別する。ネットワーク管理者はSNMPを利用時に、主に次の3つのリクエストによって、定期的あるいは必要に応じてネットワーク機器を監視する。
- GetRequest
- MIB内の特定のOIDの値を要求する。
- GetNextRequest
- MIB内の特定のOIDの次の値を要求する。
- GetBulkRequest
- 複数のOIDの値をまとめて要求する。
「RFC 1213」ではMIBの新たなバージョンとして「MIB-II」が定義された。MIB-IIではさまざまな仕様の標準化が進み、管理者はベンダーに依存せずにSNMPを利用しやすくなった。
SNMPの特徴としては、シンプルな通信プロトコル「UDP」(User Datagram Protocol)を利用するため、ネットワーク監視に必要な処理の負荷を比較的抑えることができる点が挙げられる。
だが、SNMPではポーリングのたびに、管理サーバ側からネットワーク内の各機器に情報を要求する。そのため、ポーリングの頻度次第でネットワーク内の各機器への負荷が増す。
テレメトリーの仕組み
テレメトリーによるネットワーク監視の仕様は「RFC 9232」で「Network Telemetry Framework」で策定されている。ポーリング方式のSNMPと比較して、テレメトリーではネットワーク機器から継続的にデータを送信する。そのため、SNMPに比べてネットワークの情報をリアルタイムに把握しやすくなる。
ただし、常にリアルタイムの情報を取得すると管理サーバ側が処理するデータ量が膨大になってしまう。そのため、ネットワーク管理者は、ネットワークにおける特定の項目のしきい値を超えた場合など、あらかじめ設定したイベントをトリガーとして、テレメトリーで監視を開始できる。特定のエラーの発生をトリガーとすることも可能だ。イベントを起点とした情報の収集はSNMPも可能だが、テレメトリーの方がよりリアルタイムかつ信頼性の高いネットワーク監視情報を手に入れることができる。
テレメトリーで主に利用されるデータ形式は以下の通り。
- XML(Extensible Markup Language)
- JSON(JavaScript Object Notation)
- Protocol Buffers
テレメトリーで主に利用される通信プロトコルは以下の通り。
- TCP(Transmission Control Protocol)
- UDP(User Datagram Protocol)
- gRPC(Google Remote Procedure Calls)
- gNMI(gRPC Network Management Interface)
テレメトリーを利用するとデータが膨大になる恐れがある。ネットワーク管理者は、ネットワーク管理システムの処理能力を圧迫しないよう、各種データをストリーミングするための間隔やイベントトリガーを決定しなければならない。
次回はSNMPとテレメトリーを比較する。
TechTarget発 先取りITトレンド
米国Informa TechTargetの豊富な記事の中から、最新技術解説や注目分野の製品比較、海外企業のIT製品導入事例などを厳選してお届けします。
Copyright © ITmedia, Inc. All Rights Reserved.
Computer Weekly発 世界に学ぶIT導入・活用術
この記事の著者
関連記事
新着ホワイトペーパー PR
-
製品資料
[株式会社うるる] 「入札市場」攻略ガイド:効率的に落札するためのポイントを徹底解説 -
製品資料
[株式会社うるる] 入札情報に特化した「販路拡大」「効率化」のためのサポートツールとは? -
市場調査・トレンド
[株式会社うるる] 公共入札に成功する企業と失敗する企業の「5つの違い」 -
製品資料
[日本ビジネスシステムズ株式会社] 専門家が教える、Microsoft 365の「テナント統合/分離」を成功に導く秘訣 -
製品資料
[rakumo株式会社] Microsoft 365での情報埋没を防ぐ、社内ナレッジを資産化する情報ポータル活用
こんなメディアも見られています
TechTargetジャパンに関連する情報をお探しであれば、こちらのメディアもお役に立てるかもしれません。
ベンダーコンテンツ PR
From Informa TechTarget
SpecialPR
アクセスランキング
-
1
PHP脆弱性「PHP2Shell」で2260万件に影響 情シスの緊急チェックリスト
-
2
半数がブルーカラー転向を視野に? ベテランエンジニアを追い込む“54歳の壁”
-
3
「Windows」の不要なファイルを安全に消して容量を空ける方法
-
4
「Microsoft 365」が乗っ取られる MFAを破る“本物の画面”の恐怖
-
5
なぜ「Gemini 4 Argon」は出遅れたのか? Googleが狙う“逆転のシナリオ”
-
6
「テザリング依存」に潜む落とし穴 “遅いVPN”を解消するネット構築術
-
7
Claude利用8割のGMO、AI人材の評価軸が「トークン管理」に変わった
-
8
損保ジャパンはなぜ「COBOL」を捨てなかったのか? 脱メインフレームの真相
-
9
「Wi-Fi 7」経由でWindowsが乗っ取られる? 最高権限奪取の恐怖
-
10
「IT運用・情報システム業務」に関するアンケート
ホワイトペーパーランキング PR
-
1
AI駆動攻撃にどう対抗する? 超速の攻撃からエンドポイントを保護する方法
-
2
2026年のサイバーセキュリティには何が必要か? 最新データに学ぶ傾向と対策
-
3
経験豊富な即戦力人材に直接アプローチできる、「攻めの採用」への転換術
-
4
「IT史に名を残すシステム障害」8選
-
5
最速72分でデータが流出? 最新の脅威トレンドや侵入手法から分かった防衛策
-
6
不審メールの経路や見せ方に変化? 2026年夏の3事例から見えた動向と対処方法
-
7
AI駆動開発のスピードと安全性を両立 「品質・セキュリティ管理」の実践ガイド
-
8
HDDを使わない「SSDオンリー」が無謀なのはなぜ?
-
9
「標的型攻撃メール」事例・サンプル集
-
10
Microsoft 365のメールセキュリティ、3つの“死角”と追加で検討すべき対策とは
TechTargetジャパン SNS
インフォメーション
注目情報をチェック
TechTargetジャパンをフォロー